OTB RSS Feed

A reader reports having problems with my RSS2 feed for some time but the feed validator to which he directs me says my feed is just fine and invites me to display an ugly orange banner proclaiming it as such. Is anyone else having difficulties?

FILED UNDER: OTB History
James Joyner
About James Joyner
James Joyner is Professor and Department Head of Security Studies at Marine Corps University's Command and Staff College and a nonresident senior fellow at the Scowcroft Center for Strategy and Security at the Atlantic Council. He's a former Army officer and Desert Storm vet. Views expressed here are his own. Follow James on Twitter @DrJJoyner.

Comments

  1. Tim says:

    Looks fine to me.

  2. Boyd says:

    I’ve never had a problem with your RSS feed.

    The “required preview” when posting comments is a bit annoying, but you didn’t ask about that.

    Ahem.

  3. Buck Hicks says:

    Yes I use Sharp Reader and have been having problems with your feed for a while. I think the problem is with the Square character that follows the Outside the Beltway in the title. I bet if you go to where ever you display your title, go to the end of it and us your delete key to eleiminate the character you will fix it.

  4. Buck Hicks says:

    By the way if you open the feed in Internet Explorer you will see what I am talking about. That character must not be allowed in XML/RSS pages.

    https://www.outsidethebeltway.com/wp-rss2.php

  5. elgato says:

    I get it just fine on my end.

  6. Buck Hicks says:

    I suspect that the aggregators that aren’t having a problem with it are just ignoring the error and publishing it as is.

    I just clicked the link provided by James and it shows this at the top of the page.

    Warning

    This feed is valid, but may cause problems for some users. We recommend fixing these problems.

    Your feed appears to be encoded as “iso-8859-1”, but your server is reporting “US-ASCII” [help]

    line 9, column 27: title contains bad characters (2 occurrences) [help]

  7. Boyd says:

    Buck, I also use Sharpreader and don’t experience the problem you describe. I’m using version 0.9.5.0, how about you?

  8. Boyd says:

    Oh, and I’ll bet that character that’s not displaying correctly for you is the ™ symbol.

  9. Buck Hicks says:

    I have v0.9.5.1 as well as SP2 for the .Net framework that was just released a week or so ago.

  10. Dale says:

    With Bloglines it seems to work OK.

  11. KevinM says:

    Reads fine in bloglines

  12. Rich says:

    Sorry James, I should have been a bit more detailed in my post.

    I’m using SharpReader (0.9.5.1) and it’s having problems with your title block:

    Your feed appears to be encoded as “iso-8859-1”, but your server is reporting “US-ASCII”

    <title\>Outside The Beltway&amp#153;</title>

    It’s choking on the ™ character.

  13. Rich says:

    Ack,

    Preview messes with the escaped chars, here is (I hope) the source:

    <title\>Outside The Beltway&#153;</title>

    It’s the trademark symbol.

  14. Digger says:

    I get a “forbidden” error for your feed with feedreader. Doesn’t even show the title of you site, just says forbidden before it even shows the info to add it.

  15. Candyman says:

    The square character – same with me. I’ve been having problems with your feed for a long time now and I’m using NewsGator in Outlook. I wasn’t sure if it was you or me but your feed is the only trouble I’ve had out of dozens.

  16. Chris Short says:

    I’m having issues with SharpReader and the trademark character too.

    I would call it a bug in SharpReader but if it’s not a valid RSS character then it’s not a bug.